TRX2A L4 blowed

General discussion

TRX2A L4 blowed

Postby HB9FIH » 22 May 2016 19:29

Hi Adrian
Yesterday and today I participated the "King of Spain" in CW with TRX2A and PA100D.
All wonderfull, also with the new FL2. Will be my best result in this contest.

Just 1 hour ago, I made a QSO in Olivia with France.
on 14 072 with 7 Watts on my SG239 Tuner up to ZS6BKW.
The SWR was 1:1 (nothing readable) - the tuner make the best job (the Antenna is also nearly 1:1 on this QRG.

Just before ending the QSO - no more power - TX out. :o
Suddently opend TRX2A smelled a bit, but feeld nothing especially warm or hot.
After closer inspection - I recognized the L4 is blown.

Now solution ? (and the reason ?)
I am here still until 31.May. Then next time in September. Should I unmount the PA plate an send them to (where/who ?), or get only replacement for L4,
but if there are more defective parts ? - additiona: I will check my boxes tomorrow wether I can find such a L - nearly. :idea:
Outils I am well equiped here, but not possible to get some replacement parts here.
Most parts I take with me from Europe or take from used Electronic.
-added 23.5. Datasheet found and such parts - uff 3000 pcs for 60 EUR --- need only 1.

Tnx Erich
(I am not totally without radio ;) - revised X1M here)

SAM_4810-part.jpg
Part PA Board TRX2A (L4 blowed)
vy 73 de
HB9FIH
HS0ZLS
HB9FIH
 
Posts: 24
Joined: 12 Feb 2014 21:30
Location: Switzerland but most time on journey

Re: TRX2A L4 blowed

Postby 5B4AIY » 23 May 2016 06:51

Hi Erich,
Oops! Unfortunately you seem to have discovered one of the design limitations of the Juma TRX-2 power amplifier. This PA, along with many others, is not rated for continuous 100% duty cycle operational modes such as RTTY, PSK-31, Olivia, JT-65 etc, at anywhere near maximum power. Even operation at 7W with 100% duty cycle will severely stress the PA and driver stages. If you intend to operate digital modes then as with other transceivers the power should be reduced to no more then 3W - 4W.

There are two factors that cause this limitation. The first is the PA heat-sink which is a double-sided piece of printed circuit board rather than a solid piece of aluminium. As a result, its thermal resistance is somewhat high, and this allows both the PA and the driver transistors to get quite hot.

The second is the dissipation in the coupling transformers. You will find that they too get quite hot under continuous key-down operation at maximum power. Indeed, I'm surprised that no-one has come up with a modification to replace these dissipative devices with more suitable purpose designed transformers wound on a ferrite toroid from the Amidon range. It may be that there are other over-riding design reasons for using these Wurth transformers of which I am not aware.

L4 is a Murata BLM31B601S surface-mount ferrite choke having an impedance of 600 ohms at 100MHz, and a maximum current rating of 200mA. Since you have managed to burn it out, obviously something was drawing significantly more than 200mA! You will need to remove the choke and check the driver FETs, TR2 and TR3. Assuming that C11 has not failed short-circuit, with no power, using a multi-meter with the positive lead on C11 and the negative lead on ground, you should see essentially an open-circuit, or at least a very high resistance. If instead you see a very low resistance this would indicate that one or both transistors TR2/TR3 has failed short-circuit and will need to be replaced. This is not easy. You will need to cut the two leads of the transistor, and then with a 40W iron with a wide bit and a high temperature, 330C - 360C, applied to the tab of the transistor quickly melt all the solder and lift the transistor off with a pair of tweezers. Take care not to over-heat the board. If necessary, use Solderwick to clean the pad, and the holes for the leads, and solder in a replacement. You will also need to clean the board and the pads for the replacement L4. The actual value of L4 is not all that critical. You could probably use a few turns of enamel wire wound on a small ferrite bead.

73, Adrian, 5B4AIY
5B4AIY
 
Posts: 155
Joined: 13 Nov 2011 09:22
Location: Cyprus

Re: TRX2A L4 blowed

Postby HB9FIH » 24 May 2016 14:35

OK I did.
From C11 against GND there where about 400kOhm. I feelt this is high...
Further I recognized the fuse T2.5A is blown. Bridged (only for check) .
I removed the PA board from TRX2
Then I connected a power source with current limit and increased slowly the Voltage.
The curren was significant increasing, I let them on abt 1.5 Amp and feeled the T 2 and 3
T2 becomes very hot.
I removed T2.
C11 ist now open... and the current nothing until 13 Volts.
Seems the T2 is gone ..
I will order all T and SMD "Coils" for PA - also Fuse replacements - for emergy stock..
Any others what I should get as emergy stock ?
Will change all pairs - T2/3 first then check maybe also T4/5 too
Am I right ?

SAM_4813.jpg
vy 73 de
HB9FIH
HS0ZLS
HB9FIH
 
Posts: 24
Joined: 12 Feb 2014 21:30
Location: Switzerland but most time on journey

Re: TRX2A L4 blowed

Postby 5B4AIY » 25 May 2016 06:54

Good morning, Erich,

Glad that you have managed to remove the transistors without damaging the board. There are some other checks that you should perform to ensure that your replacement transistors do not fail.

1. Bias Supply
If there is a fault in the bias supply, this can cause excessive bias current, and blow fuses. Rotate R6/R9 fully anti-clockwise (Driver stage bias) as well as R15/R18, PA stage bias. Note that these are 10-turn pots.

2. TX/RX Logic
Ensure that the transceiver switches between transmit and receive with the PTT switch as well as the key. The TX/RX switching is on the PA board, TR6/TR7 and RL1. A logic signal TX from the microprocessor controls the switching.

Before you even solder the new transistors in place reconnect the PA board, perform the TX/RX switching test, and then with a multi-meter measure the gate bias voltages of TR2/TR3 as you rotate the appropriate bias pot and verify that you can smoothly increase the voltage from zero for both transistor's gates. A fault in this circuitry could place a large positive voltage on the gate and cause the transistor to draw an excessive current, blowing the fuse. A current-limited power supply would be of great assistance here. Remember to reset the pots fully anti-clockwise, and make sure that the voltage is now zero. Once you have replaced the transistors, you will have to go through the bias current setup routine. This is described in my User Manual if you are using my firmware.

Let me know how you get on, and if you need any more assistance.

73, Adrian, 5B4AIY
5B4AIY
 
Posts: 155
Joined: 13 Nov 2011 09:22
Location: Cyprus

Re: TRX2A L4 blowed

Postby HB9FIH » 26 May 2016 08:16

Tnx Adrian - so far all clear.

I found more: see schematic, and I will remove the T3
now will order the parts (think all special parts for stock too)
(have time, will be here mid September again)
Only one Question: the IRF510 is like the IRFI510G - only its not isolated ? (there is a big price difference)
TNX a lot

Messung1.jpg
vy 73 de
HB9FIH
HS0ZLS
HB9FIH
 
Posts: 24
Joined: 12 Feb 2014 21:30
Location: Switzerland but most time on journey

Re: TRX2A L4 / TR2 / T3 broken

Postby HB9FIH » 20 Jun 2016 07:30

Adrian a question:

Do you, or some from Juma, visite HAM Radio in FNH next Weekend ?

I this case could take the replacement parts for my broken TRX2 with.
I am 3 days on the HAM.


These are the parts ( really broken ones and others for replacement stock):
TR2 (this is broken)
TR1
TR4
TR5
T1
T2
T3 (this is broken)
L4 (this is broken)
L7

Erich


Just I have found nearly all parts at
http://www.partco.biz/verkkokauppa/

only the SMD inductors not.
vy 73 de
HB9FIH
HS0ZLS
HB9FIH
 
Posts: 24
Joined: 12 Feb 2014 21:30
Location: Switzerland but most time on journey

Need help for parts

Postby HB9FIH » 04 Jul 2016 06:45

Hi OM's from OH
In my TRX2A some parts are broken.
Now I recognized where I could get all the parts -> from partco.biz (Helsinki)
But partco does deliver only within Finland.

So need help for order send to an adress in OH and then send to my adress in Germany.


the parts are Driver- and PA-Transistors, SMD-Inductor and PA-Tafo


TNX for any help Erich
vy 73 de
HB9FIH
HS0ZLS
HB9FIH
 
Posts: 24
Joined: 12 Feb 2014 21:30
Location: Switzerland but most time on journey

Re: TRX2A L4 blowed - continue 10/2016

Postby HB9FIH » 12 Oct 2016 19:26

OK Adrian,
now a long time ago I received the replacement parts and now I am back here in Turkey where the JUMA waits wor repair.
I have replaced the
T3
L4
TR2

Then by adjusting the trimmers to bias 0, I recognized the trimmer 10k R15 is also broken.
Fortunally I had one, but a vertical standing no multi turn. I taked them.
All trimmers to counter clockwise. Also jumper to DRV.

Then with current limit switched on.
Then slowly turned the R15 clockwise.
No effect long time.. suddently - low voltage. I turned back and reset this.
Again same - result : if I come to a certain position of R15 the current increased - not able to adjust - its like a switch.
Then I tried the same with R9 - same effect. Although I turned the trimmers very very slow.

It seems there is another problem too.
Do you have any suggestions ?

Next time I am here in May 2017. First I go to HS, then to EA8. Also I have time in case of sending for repair.
Either I can resolve this here, or I take the PA Backpanel with me and send it in abt mid November.

What do you mean ?
TNX Erich
btw I changed the mail adress in user profile.
vy 73 de
HB9FIH
HS0ZLS
HB9FIH
 
Posts: 24
Joined: 12 Feb 2014 21:30
Location: Switzerland but most time on journey

Re: TRX2A L4 blowed

Postby 5B4AIY » 13 Oct 2016 11:07

Hi, Erich,

I am somewhat confused by your description. Let's see if we can resolve this. First, the pots must be multi-turn, a single-turn pot adjustment is far too coarse to allow for a nice fine smooth adjustment, so your damaged pot will have to be replaced with a 10-turn unit.

As for your adjustments, R9 and R6 adjust the bias current of the driver stage; R18 and R15 adjust the bias currents of the PA stage. The first thing I would check is if the bias supply is working correctly. First set all the pots fully anti-clockwise. Key the transceiver into transmit and measure the voltage across C43. It should be approximately 5.2V, made up of 2.5V from the precision voltage reference, Z1, LM4040-2.5, plus 4 forward voltage drops of approximately 0.675V across diodes D7 and D8, BAV99. If a diode is open, then the voltage across C43 will be much higher than 5.2V, probably around 8V. Note, this will depend, to some extent upon the supply voltage.

Next, with the current selector on the DRV position, so that the ammeter displays the driver stage current, carefully rotate R6 clockwise and verify that you can smoothly increase the driver stage transistor TR2 bias current from zero to 30mA. Then, rotate R6 anti-clockwise and reduce the bias current back to zero. Now rotate R9 clockwise and verify that you can smoothly increase the driver stage transistor TR3 bias current from zero to 30mA. This will verify that both TR2 and TR3 are actually working correctly. Any sudden jumps in current, or any inability to smoothly increase and decrease the currents indicates a fault.

With both R6 and R9 rotated fully anti-clockwise so that the driver stage transistors are turned off, swap the current selector over to the PA position, ensure that both R15 and R18 are set fully anti-clockwise. Now key the transceiver into transmit and carefully rotate R15 and verify that you can smoothly increase the bias current of TR4 from zero to 100mA. Then rotate R15 back to zero and ensure that the current has reduced to zero and repeat using R18, verifying that TR5 is working correctly.

Again, any sudden jumps in current or any inability to smoothly increase/decrease the currents indicates a fault. Since these adjustments are being made under DC bias conditions if both the bias supply and the transistors are working then it should be possible to smoothly alter the bias currents. Since the transistors are IGFETS, there should not be any current drawn from the bias supply, and if you find that the bias voltage across C43 changes abruptly as you alter the bias pots, then this would indicate a bad transistor.

Let me know what you find.
73, Adrian, 5B4AIY
5B4AIY
 
Posts: 155
Joined: 13 Nov 2011 09:22
Location: Cyprus

Re: TRX2A L4 blowed

Postby HB9FIH » 14 Oct 2016 17:22

TNX Adrian

I removed both IRFR110 (Drivers)
Following checked:

The Bias Voltage is 5.22 V
Then with R6 / R9 / R18 / ( R15 is broken) - I can regulate the Voltage very smooth.
Then checked all resistors around - and found: R23 / R24 are also blown (same in Driver stage are ok 1.1Ohm)
Next will put in the IRFR110 and adjust the Drivers Bias.
Thats all I can do for now.
Then write a shopping list for get parts, but here (TA3) no chance.
I will then prepare these parts for my next visite here.

I message again asap next step.
Erich
vy 73 de
HB9FIH
HS0ZLS
HB9FIH
 
Posts: 24
Joined: 12 Feb 2014 21:30
Location: Switzerland but most time on journey

Next

Return to Juma Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron