TX136/500 WSPR modes added

General discussion

TX136/500 WSPR modes added

Postby F4GCB » 08 Oct 2014 15:14

Hello the TX136/500 builders,

WSPR is a very interesting mode for 2200 and 630 meters bands.

So thanks to the K1JT WSPR source code, the G4JNT algorithm description and the W3PM source code examples,
it has been relatively easy to add the WSPR modes in the TX136/500 software.

The result of this work is a new unofficial version 1.06a which changes :
- added WSPR-2 and WSPR-15 modes (standard WSPR messages only : callsign + 4 digit locator + dBm)
- added WSPR timer calibration in the service mode menu (an accurate timer is mandatory in WSPR mode)
- added optional GPS NMEA ($GPGGA) RS232 serial input for perfect synchronization.

The TX136/500 remains a stand-alone device, the PC is used just to program the WSPR parameters.

Having no TX500 this software has been validated on TX136.
The GPS synchronization has been tested with an Adafruit GPS module with serial TTL-RS232 converter.
For the ones who will try it, thanks in advance for your feedback.

73, Patrick F4GCB
Attachments
TX136-500 v1.06a (C-source+HEX load file+instructions).zip
WSPR modes added
(476.37 KiB) Downloaded 358 times
F4GCB
 
Posts: 23
Joined: 27 Aug 2014 19:03
Location: France

Re: TX136/500 WSPR modes added

Postby F4GCB » 09 Oct 2014 05:02

Hello,

I have been too quick to write the WSPR user’s guide and this last is incomplete.
This new version corrects the mistake.

73, Patrick F4GCB
Attachments
wspr-user-guide_v_106a.zip
(93.1 KiB) Downloaded 364 times
F4GCB
 
Posts: 23
Joined: 27 Aug 2014 19:03
Location: France

Re: TX136/500 WSPR modes added

Postby JH1GVY » 03 Dec 2014 13:04

I installed v1.06a in TX500 and tried WSPR beacon.
The result is very wonderful.
The reception result by the indoor experiment by the dummy load was uploaded in WSPRnet. Anyone can watch it by searching it in JH1GVY.
Only one might be mysterious. The situation is the following states.
I set TX500 in BEACON mode and short-circuited in pin J4(2P).
And it supplies the voltage to TX500 from DC power-supply unit. Then TX500 starts the transmission with WSPR beacon mode automatically.
However, it is a carrier wave of no modulation. Symbol numbers increase during the transmission, but symbol value always remain 0. When I stop a beacon and reopen immediately, right WSPR signal is provided.
How may I solve a problem that this symbol value always remains 0?
JH1GVY
 
Posts: 27
Joined: 22 Jan 2014 20:29
Location: Japan

Re: TX136/500 WSPR modes added

Postby F4GCB » 04 Dec 2014 05:10

Hi Mori,

Thanks for your feedback.
I appreciate to know that the WSPR mode works in TX500.

Indeed the problem is due to a bug in the firmware.
The call, grid and power are stored in eeprom, not the WSPR message.
The WSPR message is performed only with a long OPER button push.
Therefore after an automatically restart it remains empty.

Please find the version 1.06b which should fix this bug.
I wrote « should » because I am away on business without a TX for test the fixed bug.

73, Patrick F4GCB.
Attachments
TX136-500 v1.06b (HEX load file).zip
WSPR message empty after automatically restart fixed.
(57.88 KiB) Downloaded 330 times
F4GCB
 
Posts: 23
Joined: 27 Aug 2014 19:03
Location: France

Re: TX136/500 WSPR modes added

Postby JH1GVY » 04 Dec 2014 12:11

In V1.06b, the issue of no modulation of the WSPR beacon was settled.
Thank you.

There are two questions.
1. When J4 does not short-circuit, PIC cannot program. Is this right?
The environment; MPLAB IDE(v8.92), PICkit3(In-circuit Debugger/Programmer)
PICkit3 connects with J19(6P).
The IDE emits the following messages;
--------------------------------------------
Target Detected
Device ID Revision = 00001040
Programming...
Programming failed Target Vdd not detected.
Please ensure the target device is connected.
-------------------------------------------
And TX500 becomes power off.

2. It becomes same Cal mult in all PWR when I change the value of Forward PWR Cal mult of one PWR. Is this right?
JH1GVY
 
Posts: 27
Joined: 22 Jan 2014 20:29
Location: Japan

Re: TX136/500 WSPR modes added

Postby JH1GVY » 05 Dec 2014 02:45

A user seems to fall into confusion, I think that the movement of "Mode type" of CNFIG is not suitable.
Setting of "CW Keyer type" turns into "Beacon" when I operate "Mode type".
"CW Keyer type" changes in "Beacon" even if I come back to "CW" again after beginning in "CW" by operation of "Mode type", and having displayed other Mode with UP/DOWN button.
When I do "Mode type" outside "CW", I do not see "CW Keyer type".
In other words "Mode type" controls "CW Keyer type", and independency of "CW Keyer type" is violated.
A user in this way falls into confusion.

My idea;
1. "Mode type" and "CW Keyer type" move independently mutually.
2. When I choose "CW" in "Mode type", Kyer of CW should obey setting of "CW Keyer type".
3. I can look and do "CW Keyer type" even if I do "Mode type" outside "CW".
JH1GVY
 
Posts: 27
Joined: 22 Jan 2014 20:29
Location: Japan

Re: TX136/500 WSPR modes added

Postby F4GCB » 05 Dec 2014 05:16

Hi Mori,

In reply to your first post :
1) The jumper J4 must be installed because the power switch is software controlled.
You should use the boot loader method which is easier than the PICkit 3 tool to upload the firmware to the TX500.
Seehttp://www.jumaradio.com/juma-trx2/bootloader/JUMA_Boot_Loader.html
2) Yes, the forward power calibration value is shared for all power settings.

Thanks for your suggestions for a new firmware release.

73, Patrick F4GCB
F4GCB
 
Posts: 23
Joined: 27 Aug 2014 19:03
Location: France

Re: TX136/500 WSPR modes added

Postby JH1GVY » 05 Dec 2014 06:32

Hi Patrick,
Thank you for advice.

I attached water fall of WSPR-15. It is a beautiful spectrum.
An indoor transmission and reception report of WSPR-15 is uploaded in WSPRnet.org.
http://wsprnet.org/drupal/wsprnet/spots
Attachments
w15-fall.jpg
w15-fall.jpg (24.43 KiB) Viewed 8021 times
JH1GVY
 
Posts: 27
Joined: 22 Jan 2014 20:29
Location: Japan

Re: TX136/500 WSPR modes added

Postby 7L1RLL » 05 Dec 2014 23:23

Hi Patrick
It's amaging !!
I have loaded V106b on my TX500 through PICKIT3.
Would you please make hexa file for "Portable in Japan" which will eliminate MAX(60W) power.
Thank you for in advance.
Rick 7L1RLL

PS. I successed to compile of v106a+limitation on max power and program to device using MPLAB X(v1.90) and XC16 compiler(V1.23) today.
Tentavely my version is called as v106j.
Thank you.
Last edited by 7L1RLL on 09 Dec 2014 15:13, edited 1 time in total.
7L1RLL
 
Posts: 20
Joined: 22 Feb 2012 07:43
Location: Japan

Re: TX136/500 WSPR modes added

Postby JH1GVY » 06 Dec 2014 07:09

It is the information about the WSPR-15 mode as follows.
I set TX500 in WSPR-15 BEACON mode and short-circuited in pin J4(2P).
It supplies DC14V to TX500 at the time of 0 minutes 0 seconds.
Then internal WSPR timer is set at 0:00, and first WSPR-15 Beacon is transmitted automatically after waiting for 15 minutes.
It is long waste time of 15 minutes. I point out the following things.
Delay Time(DT) of WSPR-15 of WSPR-X decoder (v0.8 r3058) is permitted more than +60 second (the transmission side is 60 seconds late behind a reception side clock). In a figure of reception that I attached, decode of WSPR-15 succeeds in DT more than 60 seconds.
The minus side is -5 second (the transmission side is five seconds faster).
Therefore, I do not have any problem if I transmit within 60 seconds without waiting for 15 minutes.
In addition, in WSPR-2, it is +6.5 second (the transmission side is 6.5 seconds late), -2.5 second (the transmission side is 2.5 seconds faster).
Attention is necessary for the frequency drift of the 6MHz master clock of TX500 in WSPR-15.
When there is frequency drift to the master clock, WSPR transmission frequency drifts.
Because TX500 starts, internal temperature rise begins. As a result, the frequency drift of the 6MHz clock occurs and may not decode it on the reception side.
Because a master clock of 6MHz is changed for TCXO in my TX500, the big frequency drift does not occur.
See attachement for frequency drift.
Attachments
Freq_Drift_vs_RFPWR.jpg
Frequncy Drift
Freq_Drift_vs_RFPWR.jpg (46.73 KiB) Viewed 7968 times
w15_delay4.jpg
Delay Time
Last edited by JH1GVY on 07 Dec 2014 01:28, edited 2 times in total.
JH1GVY
 
Posts: 27
Joined: 22 Jan 2014 20:29
Location: Japan

Next

Return to Juma Discussion

Who is online

Users browsing this forum: No registered users and 2 guests